Update spot-client to 0.1.11

This commit is contained in:
Daniel Peukert 2021-03-17 23:03:09 +01:00
parent c1a7888bf9
commit 01e1d30c36
3 changed files with 2 additions and 42 deletions

View file

@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
pkgver = 0.1.10.r1.g2dc7225
pkgver = 0.1.11.r28.gca32e38
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64

View file

@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='spot'
pkgname="$_projectname-client-git"
pkgver='0.1.10.r1.g2dc7225'
pkgver='0.1.11.r28.gca32e38'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')

View file

@ -1,40 +0,0 @@
diff --git a/build-aux/test.sh b/build-aux/test.sh
index f8ca912..f3b9e8f 100644
--- a/build-aux/test.sh
+++ b/build-aux/test.sh
@@ -2,10 +2,19 @@
export SRC="$1"
export CARGO_TARGET_DIR="$2"/target
-export OFFLINE="$3"
+export BUILDTYPE="$3"
+export OFFLINE="$4"
+
+echo $BUILDTYPE
+
+if [[ $BUILDTYPE = "release" ]]; then
+ PROFILE_ARG="--release"
+else
+ PROFILE_ARG="--verbose"
+fi
if [[ $OFFLINE = "true" ]]; then
export CARGO_HOME="$SRC"/cargo
fi
-cargo test --manifest-path "$SRC"/Cargo.toml
\ No newline at end of file
+cargo test --manifest-path "$SRC"/Cargo.toml "$PROFILE_ARG"
\ No newline at end of file
diff --git a/src/meson.build b/src/meson.build
index 93d7387..909e9d6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -140,6 +140,7 @@ test('Unit tests',
args: [
meson.source_root(),
meson.build_root(),
+ get_option('buildtype'),
get_option('offline') ? 'true' : 'false'
]
)