Disable the spot-client Clippy test

This commit is contained in:
Daniel Peukert 2021-07-31 13:57:48 +02:00
parent f02ce2e936
commit a9ef7fdf5a
3 changed files with 37 additions and 4 deletions

View File

@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
pkgver = 0.1.14.r21.g30caeaa
pkgver = 0.1.15.r6.gac86fe7
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64
@ -24,6 +24,8 @@ pkgbase = spot-client-git
provides = spot-client
conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot
source = disable-clippy-test.diff
sha256sums = SKIP
sha256sums = 5420e171e7ba18bf1f7bcdfe02210aa9a5f24f416157e5a113d305864a2c4580
pkgname = spot-client-git

View File

@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='spot'
pkgname="$_projectname-client-git"
pkgver='0.1.14.r21.g30caeaa'
pkgver='0.1.15.r6.gac86fe7'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@ -13,12 +13,23 @@ makedepends=('cargo' 'git' 'meson>=0.50.0')
checkdepends=('appstream-glib')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
source=("$pkgname::git+$url")
sha256sums=('SKIP')
source=(
"$pkgname::git+$url"
'disable-clippy-test.diff'
)
sha256sums=('SKIP'
'5420e171e7ba18bf1f7bcdfe02210aa9a5f24f416157e5a113d305864a2c4580')
_sourcedirectory="$pkgname"
_builddirectory='build'
prepare() {
cd "$srcdir/$_sourcedirectory/"
# Disable Clippy test for now, as it still complains about some errors not yet fixed by upstream
# When reenabling, don't forget to use a patch to explicitly specify the Cargo.toml path (https://github.com/xou816/spot/issues/252#issuecomment-880941157)
patch --forward -p1 < '../disable-clippy-test.diff'
}
pkgver() {
cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'

20
disable-clippy-test.diff Normal file
View File

@ -0,0 +1,20 @@
diff --git a/src/meson.build b/src/meson.build
index 829db1b..568d07b 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -185,14 +185,3 @@ test('Unit tests',
],
timeout: 180
)
-
-cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
-test('Clippy',
- cargo_clippy,
- args: [
- meson.source_root(),
- meson.build_root(),
- get_option('offline') ? 'true' : 'false'
- ],
- timeout: 180
-)
\ No newline at end of file