Update spot-client to 0.3.0

This commit is contained in:
Daniel Peukert 2022-01-16 16:36:30 +01:00
parent 07c1b3f2d1
commit ffd2bd58e1
3 changed files with 4 additions and 27 deletions

View File

@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
pkgver = 0.2.2.r36.g899a46b
pkgver = 0.3.0.r3.g1812877
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64
@ -28,8 +28,6 @@ pkgbase = spot-client-git
provides = spot-client
conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot
source = clippy.diff
sha512sums = SKIP
sha512sums = 8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599
pkgname = spot-client-git

View File

@ -2,7 +2,7 @@
# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_projectname='spot'
pkgname="$_projectname-client-git"
pkgver='0.2.2.r36.g899a46b'
pkgver='0.3.0.r3.g1812877'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@ -14,23 +14,12 @@ makedepends=('cargo' 'git' 'meson>=0.50.0')
checkdepends=('appstream-glib')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
source=(
"$pkgname::git+$url"
'clippy.diff'
)
sha512sums=('SKIP'
'8051c21a00c981eef8f0b08f30b369f28cd08d9d8d13b9f05df61b8365fc8ea91534aea7f21fcad6f14b41577fdfc9eaaf64dbd720d051e302fc7222d8aaf599')
source=("$pkgname::git+$url")
sha512sums=('SKIP')
_sourcedirectory="$pkgname"
_builddirectory='build'
prepare() {
cd "$srcdir/$_sourcedirectory/"
# Until they're fixed upstream, ignore some newly thrown errors from clippy 1.57
patch --forward -p1 < "$srcdir/clippy.diff"
}
pkgver() {
cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'

View File

@ -1,10 +0,0 @@
diff --git a/build-aux/clippy.sh b/build-aux/clippy.sh
index f60004b..22bdf6a 100644
--- a/build-aux/clippy.sh
+++ b/build-aux/clippy.sh
@@ -8,4 +8,4 @@ if [[ $OFFLINE = "true" ]]; then
export CARGO_HOME="$SRC"/cargo
fi
-cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default
+cargo clippy --manifest-path "$SRC"/Cargo.toml -- -D warnings -A clippy::module_inception -A clippy::new_without_default -A dead-code -A clippy::large-enum-variant -A clippy::redundant-closure -A clippy::derivable-impls