Remove Clippy test patch from spot-client-git, as it's been fixed upstream

This commit is contained in:
Daniel Peukert 2021-07-31 14:27:24 +02:00
parent a9ef7fdf5a
commit ec2345ced4
3 changed files with 4 additions and 37 deletions

View file

@ -1,6 +1,6 @@
pkgbase = spot-client-git pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version pkgdesc = Gtk/Rust native Spotify client - git version
pkgver = 0.1.15.r6.gac86fe7 pkgver = 0.1.15.r9.g6c66125
pkgrel = 1 pkgrel = 1
url = https://github.com/xou816/spot url = https://github.com/xou816/spot
arch = x86_64 arch = x86_64
@ -24,8 +24,6 @@ pkgbase = spot-client-git
provides = spot-client provides = spot-client
conflicts = spot-client conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot source = spot-client-git::git+https://github.com/xou816/spot
source = disable-clippy-test.diff
sha256sums = SKIP sha256sums = SKIP
sha256sums = 5420e171e7ba18bf1f7bcdfe02210aa9a5f24f416157e5a113d305864a2c4580
pkgname = spot-client-git pkgname = spot-client-git

View file

@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <daniel@peukert.cc> # Maintainer: Daniel Peukert <daniel@peukert.cc>
_projectname='spot' _projectname='spot'
pkgname="$_projectname-client-git" pkgname="$_projectname-client-git"
pkgver='0.1.15.r6.gac86fe7' pkgver='0.1.15.r9.g6c66125'
pkgrel='1' pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version' pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64') arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@ -13,23 +13,12 @@ makedepends=('cargo' 'git' 'meson>=0.50.0')
checkdepends=('appstream-glib') checkdepends=('appstream-glib')
provides=("$_projectname-client") provides=("$_projectname-client")
conflicts=("$_projectname-client") conflicts=("$_projectname-client")
source=( source=("$pkgname::git+$url")
"$pkgname::git+$url" sha256sums=('SKIP')
'disable-clippy-test.diff'
)
sha256sums=('SKIP'
'5420e171e7ba18bf1f7bcdfe02210aa9a5f24f416157e5a113d305864a2c4580')
_sourcedirectory="$pkgname" _sourcedirectory="$pkgname"
_builddirectory='build' _builddirectory='build'
prepare() {
cd "$srcdir/$_sourcedirectory/"
# Disable Clippy test for now, as it still complains about some errors not yet fixed by upstream
# When reenabling, don't forget to use a patch to explicitly specify the Cargo.toml path (https://github.com/xou816/spot/issues/252#issuecomment-880941157)
patch --forward -p1 < '../disable-clippy-test.diff'
}
pkgver() { pkgver() {
cd "$srcdir/$_sourcedirectory/" cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g' git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'

View file

@ -1,20 +0,0 @@
diff --git a/src/meson.build b/src/meson.build
index 829db1b..568d07b 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -185,14 +185,3 @@ test('Unit tests',
],
timeout: 180
)
-
-cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
-test('Clippy',
- cargo_clippy,
- args: [
- meson.source_root(),
- meson.build_root(),
- get_option('offline') ? 'true' : 'false'
- ],
- timeout: 180
-)
\ No newline at end of file